New DirecTV Guide & Menu

GopherM

Darwin was right
About a month ago DirecTV uploaded a new program guide and a new menu format. While everyone hates change we all tend to adapt to it after a while. After a month I have only found more reasons to hate it. My most recent experience came when for some reason my home WiFi router got dropped from the DirecTV link. When I brought up the Menu and went to settings it only gave the option to "Reconnect". When I select that it just went into a circular search for the network and kept telling me it couldn't connect and that I needed to reset my network router. I knew that wasn't the problem but did it anyway. After that didn't work I tried to manually configure the internet connection and that lead nowhere. I did a reset on the DirecTV box and still no luck. Then I finally went to the DirecTV support help site and found that the setup steps were still for the old menu and settings and had nothing to do with the new options.

After about an hour of plowing my way through I finally got it to let me go through the manual steps to complete the setup. I went to the online support chat site to seek help and then they agreed that online steps at the support site were no longer correct. He also agreed that the old guide and menu were better than what we now have. The support rep was very friendly and asked me what steps I took to get everything reconnected.

If you have the same problem don't expect a lot of help from the DirecTV online solutions, chat, or customer support over the phone. And good luck getting yourself back online.
 

MiddleGround

Active Member
Whatever you do... DO NOT upgrade to the Genie 2 system (the one with the wireless bridge and wireless mini-receivers)

I have called DTV so many times that they finally cut my bill 70% for 1 year! This thing constantly cycles power on it's own, has frequent 10-second pauses in the middle of shows and commercials, drops connections in the middle of streaming to the clients, and it will cause DVR'd shows to just corrupt in the middle.

I told them the next time I call, they will either give me back my original Genie System or I will never sign with them again (6 months left on contract)
 

GopherM

Darwin was right
Mine did an auto update. Yesterday it started searching for a connection about every 20 seconds and then the video coming back on. I tried switching the mini receivers but no luck. I finally unplugged the DTV router for about 30 sec and when everything came back up it finally got stable and worked like it was supposed to. I probably still have the Genie 1. It was the system installed in 2015 when we moved to this house.
 

MiddleGround

Active Member
Mine did an auto update. Yesterday it started searching for a connection about every 20 seconds and then the video coming back on. I tried switching the mini receivers but no luck. I finally unplugged the DTV router for about 30 sec and when everything came back up it finally got stable and worked like it was supposed to. I probably still have the Genie 1. It was the system installed in 2015 when we moved to this house.
If you have a coax cable going into your mini clients then it is the Genie 1 system. The Genie 2 has wireless mini clients.
 

GopherM

Darwin was right
It did it again

If you have a coax cable going into your mini clients then it is the Genie 1 system. The Genie 2 has wireless mini clients.
Yeah! Mine is the Genie 2. I had the same problem again today where the downstairs mini went back into the cycle of "Connecting" and then about 20 seconds of video and then back to "Connecting". I took the bedroom mini downstairs and swapped them out (since it was working OK). It wouldn't work at all down there and it is directly below the bridge modem down there. I took both minis to the bedroom and they both went into the "Connecting" cycle. I finally used the "Reset" option and everything came back. I had just done a reset about 2 weeks ago and the downstairs mini didn't start acting up until about 4 or 5 days ago. Hopefully everything will keep working. This is the first problem I have had in the 3 years we have had it installed.

I like the Genie and minis but I really hate the new guide and menu. I went with that equipment because this is an older home with plaster walls and I didn't want to have a bunch of holes bored and cables run.
 

GopherM

Darwin was right
UPDATE!!! The DirecTV Forum has tons of complaints about the latest software update and the problems it is causing. They are in the process of updating the software for the GUI and admit that the current update is also causing slow response times when trying to make selections from the various guides. In addition to slow response times the search functions have also been adversely affected. On my Genie, if we have a power outage I will lose my WiFi connection when the Genie comes back on. I either have to power the unit down or go through the reset process to get it to reconnect. This also seems to be a problem listed by some other users. No date has been set for the new release.
 
Top